Content

Esta guía se aplica a aquellos que han instalado Redmine y quieren actualizarse a Easy Redmine. Los mismos pasos también se utilizan para instalar las actualizaciones de Easy Redmine existentes. Esta guía indica cómo utilizar el instalador de Redmine para actualizar Redmine.

0) Antes de empezar

Asegúrate de que tienes la configuración correcta del servidor de hardware y software como se describe aquí. Más información útil:

  • El servidor web debe tener acceso COMPLETO a las carpetas public, files, log, tmp => ¡NO EJECUTAR EL INSTALADOR DE REDMINE BAJO LA RAÍZ!
  • El servidor web de Webrick NO es compatible
  • Para los plugins de Easy Redmine ve a [redmine_root]/plugins/easyproject/easy_plugins
  • La instalación NO configura CRON automáticamente, hay que hacerlo manualmente
  • Para el correcto funcionamiento del instalador de Redmine, se requieren al menos 250 MB libres en el disco raíz
  • El servidor debe tener una conexión a Internet sin restricciones, al menos en el momento de la instalación
  • Redmine no puede contener plugins o modificaciones de terceros. Más en el punto 2.1 de las condiciones de instalación
  • Para el buen funcionamiento de Easy Redmine recomendamos esta configuración de servidor
  • Antes de actualizar el Easy Redmine existente, revisa el contenido de las carpetas de plugins en tu instalación actual y en el paquete de actualización (/plugins y /plugins/easyproject/easy_plugins). Si al paquete de actualización le faltan algunos plugins que están en la instalación actual, escribe al Esta dirección de correo electrónico está siendo protegida contra los robots de spam. Necesita tener JavaScript habilitado para poder verlo. para averiguar por qué y para obtener el paquete correcto. O simplemente desinstala los plugins excesivos de tu sistema.

También se puede encontrar un manual de instalación detallado directamente en el paquete* en doc/INSTALL
* Desde la versión de plataforma 05.02

1) Instalador de Redmine Ruby Gem

En primer lugar, tienes que instalar el instalador de Redmine Ruby Gem. Para instalar la gema usa:

$ gem install redmine-installer

(O gem update redmine-installer para actualizar la gema existente a la última versión.)

Cuando la gem instaladora esté instalada/actualizada en tu Ruby, puedes empezar con la actualización.

¡Solicita la descarga del instalador!

2) Actualización de la instancia existente de Redmine

El instalador de Redmine puede actualizar tu Redmine existente desde el archivo o el repositorio git. Los plugins instalados se conservan o actualizan si un nuevo paquete los contiene.

El procedimiento de actualización se puede guardar en un perfil para la próxima actualización. Los perfiles se almacenan en HOME_FOLDER/.redmine-installer-profiles.yml

Comando para la actualización:

redmine upgrade [PATH_TO_PACKAGE] [REDMINE_ROOT]

El asistente de actualización te lleva a través de los siguientes pasos:

1) Raíz de Redmine - define dónde está instalado tu Redmine (si no lo has incluido ya en el comando)
2) Cargar el paquete - cargar el paquete en la carpeta temporal
3) Validación del Redmine actual
4) Copia de seguridad - completa / configuración + base de datos / solo base de datos
5) Actualización - los comandos de actualización se ejecutan
6) Mover Redmine - el Redmine actual se actualiza con nuevos archivos
7) Guardar el perfil - el procedimiento de actualización se guarda para un uso futuro

Comando para la actualización de Redmine - desde archivo

redmine upgrade [PATH_TO_PACKAGE] [REDMINE_ROOT]

Ejemplo

redmine upgrade easyredmine_2016_stable_u11271_v2018_1_2__platform_04_00.zip /home/easy/current

Comando para la actualización de Redmine - desde perfil

redmine upgrade [PACKAGE] [REDMINE_ROOT] --profile PROFILE_ID

Actualización con modificaciones personalizadas

Si estás usando el plugin easyproject y no quieres copiar las modificaciones del cliente de la instancia anterior, usa switch

--skip-old-modifications

Si estás usando el plugin easyproject y no quieres copiar las modificaciones del cliente de la instancia anterior, usa switch

·      Antes de actualizar el Easy Redmine existente, revisa el contenido de las carpetas de plugins en tu instalación actual y en el paquete de actualización (/plugins y /plugins/easyproject/easy_plugins). Si al paquete de actualización le faltan algunos plugins que están en la instalación actual, escribe al Esta dirección de correo electrónico está siendo protegida contra los robots de spam. Necesita tener JavaScript habilitado para poder verlo. para averiguar por qué y para obtener el paquete correcto. O simplemente desinstala los plugins excesivos de tu sistema.

Descubre Easy Redmine con la prueba gratuita de 30 días

Versión completa, 30 días, certificado SSL, backups diarios, ubicación In your Geo

o