Content

Redmine 2.6.3 is supported

Easy Redmine version 5.5 now runs on Redmine 2.6.3. It is the required version to install Easy Redmine.

Due to instabilities in Redmine 3, the support of this version is postponed until all dependencies and bugs are settled. Thank you for staying patient!

Additional information
Free Trial

Easy Redmine 2018 upgrade
Top plugins & features
New & mobile design
Server upgrades
Global cloud

Start Free Trial

Easy Redmine 2018 Free Trial

Full-featured, 30 Days, SSL protected, Daily Backups, In your Geo Location

or